Unable to compile against staged boost

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to compile against staged boost

Joseph M Redfern
I am trying to compile graph-tool 2.22. I'm running Python 3.6.2 with pyenv, and have a staged boost 1.6.64 (linked against my pyenv 3.6.2 install). I do not wish to install boost globally, as it may cause conflicts with my system Python (3.5.x). 

I am running the following commands:

./autogen.sh
./configure CPPFLAGS="-I/home/joe/Research/graphbooze/libs/boost_1_64_0/" LDFLAGS="-L/home/joe/Research/graphbooze/libs/boost_1_64_0/stage/lib -Wl,-rpath=/home/joe/Research/graphbooze/libs/boost_1_64_0/stage/lib"


but am faced with the error "configure: error: Could not link against boost_regex ". I am using the configure flags taken from the graph-tool wiki, and am hoping that my include path folder is correct? Boost's lib directory includes multiple libboost_* files, and I have linked 'libboost_python3' to 'boost_python3' as it was previously causing errors. I'm not sure if that could be related to this problem too, but linking libboost_regex to boost_regex didn't solve the problem.

I have attached config.log. I am not entirely sure if this is a boost issue or a graph-tool issue -- the boost compile went through without issue. Any help or direction (even if it's just confirming that it's a boost issue rather than graph-tool) would be much appreciated.

Thanks,
Joe

_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool

config.log (119K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to compile against staged boost

Tiago Peixoto
Administrator
On 20.07.2017 17:48, Joseph M Redfern wrote:

> I am trying to compile graph-tool 2.22. I'm running Python 3.6.2 with pyenv,
> and have a staged boost 1.6.64 (linked against my pyenv 3.6.2 install). I do
> not wish to install boost globally, as it may cause conflicts with my system
> Python (3.5.x).
>
> I am running the following commands:
>
> ./autogen.sh
> ./configure CPPFLAGS="-I/home/joe/Research/graphbooze/libs/boost_1_64_0/"
> LDFLAGS="-L/home/joe/Research/graphbooze/libs/boost_1_64_0/stage/lib
> -Wl,-rpath=/home/joe/Research/graphbooze/libs/boost_1_64_0/stage/lib"
>
>
> but am faced with the error "configure: error: Could not link against
> boost_regex ". I am using the configure flags taken from the graph-tool
> wiki, and am hoping that my include path folder is correct?
Could you please try with the git version as well, and also provide the full
output of the configure script?

> Boost's lib
> directory includes multiple libboost_* files, and I have linked
> 'libboost_python3' to 'boost_python3' as it was previously causing errors.
> I'm not sure if that could be related to this problem too, but linking
> libboost_regex to boost_regex didn't solve the problem.

This does not make much sense, as the "lib" prefix is standard and expected.
Furthermore, if you have to do things like this by hand, then there is
something wrong with your installation.

Best,
Tiago

--
Tiago de Paula Peixoto <[hidden email]>


_______________________________________________
graph-tool mailing list
[hidden email]
https://lists.skewed.de/mailman/listinfo/graph-tool

signature.asc (849 bytes) Download Attachment
--
Tiago de Paula Peixoto <tiago@skewed.de>
Loading...